RadiAnt DICOM Viewer - Discussion Forum
Is it inconvenient to cooperate with other systems?

The RadiAnt DICOM Viewer can be integrated with other systems using command line arguments or the radiant: // URL protocol.

However, as a result of the test I could not read more than one study.
This can not be compared with past images.
Please tell me a nice way.

Feb 27, 2018 04:55 AM
by yamada
We will try to make possible downloading several studies using only one command. Please check our beta version log once in a while.

Mar 1, 2018 09:19 AM
by RadiAnt
I couldn't find the way in latest beta version log.


I tried to read two studies, but it doesn't work.

radiantviewer.exe -pstv 0020000D """"


radiantviewer.exe -pstv 0020000D ""-pstv 0020000D""

please tell me collect way.

Mar 8, 2018 04:56 AM
by yamada
Please try our latest (4.5.10) beta version.
We have improved the commands so that several different studies/series/images can be downloaded with a single command.

A few examples:

1) Two studies:
radiantviewer.exe -pstv 0020000D "STUDYUID1" -pstv 0020000D "STUDYUID2"

2) Two series of the same study:
radiantviewer.exe -pstv 0020000D "STUDYUID1" -pstv 0020000E "SERIESUID1" -pstv 0020000E "SERIESUID2"

3) Different series from two different studies
radiantviewer.exe -pstv 0020000D "STUDYUID1" -pstv 0020000E "SERIESUID1" -pstv 0020000E "SERIESUID2" -pstv 0020000D "STUDYUID2" -pstv 0020000E "SERIESUID3" -pstv 0020000E "SERIESUID4"

4) Several images from different series of the same study:
radiantviewer.exe -pstv 0020000D "STUDYUID1" -pstv 0020000E "SERIESUID1" -pstv 00080018 "INSTANCEUID1" -pstv 00080018 "INSTANCEUID2" -pstv 0020000E "SERIESUID2" -pstv 00080018 "INSTANCEUID3" -pstv 00080018 "INSTANCEUID4"

Let us know if the new version works for you well.

Mar 9, 2018 05:46 PM
by RadiAnt
Thumbs extremely up.

Mar 9, 2018 10:53 PM
by Aaaaaaaa
thank you for great improvement.

i tried to do test latest beta version(4.5.10). but, Error appears and i coudn't read study with the latest version of radiantviewer.exe -pstv 0020000D「STUDYUID1」.

so, I returned to (4.2.1)or(4.5.9) version from (4.5.10)and it works.

perhaps, there are bags in latest version (4.5.10).

connection Server is Conquest SRV.

Mar 12, 2018 03:25 AM
by yamada
Could you contact us directly: https://www.radiantviewer.com/contact/ so that we could work together to resolve your issue?

Mar 12, 2018 07:53 AM
by RadiAnt
thank you for replying me.
i sent movie of the problem in command line from contact form.

Mar 13, 2018 02:47 AM
by yamada
Thank you for reporting the issue. It has been fixed.

Mar 15, 2018 07:30 AM
by RadiAnt
Post reply