Sign in
RadiAnt DICOM Viewer - Discussion Forum
Unable to download studies over network.

Sep 10, 2017 09:52 AM
by The Radiologist
I have a Radiant trial license. I am unable to download studies over PACS network though I am able to view the list of studies done. Radiant attempts to download initially (xxx bytes) and then drops to o bytes. The PACS admins say everything has been properly configured (and it had been working well till 1 month back). I am not able to figure out what is wrong. Please help.
Sep 12, 2017 12:10 PM
by Tommy
I'm experiencing a very similar issue on a Win7 32bit computer in my workplace using a licensed copy of RadiAnt

this one stopped working in August and never resumed downloading studies.

it can query the PACS and retrieve the list but cannot download images.

I have many other PC in the same network (all are Win7 x64) which only occasionally fail to download studies, but this one in completetly down all the time.

Is there any way I can debug it?
Sep 13, 2017 12:55 PM
by Tommy
it says my IP and AET have to be configured in the PACS

I checked and the configuration is apparently correct...
anyway, it can query the list but it doesn't download any image.

may the listener port 11112 be cause of the issue?
is there a different port number I can try to use?

the other RadiAnt copies I have in other computer of the same network work well with the same PACS and the same 11112 port.
Sep 14, 2017 09:28 AM
by vinu
This problem happening because of same AE title used in other system.

Just change the AE title of RADIANT. By default it would be RADIANT. Try to change RADIANT to some other name. For instance , RADIANT123.

There is no need to change the listener port. it could be same.
I believe this solution will work out for your problem.
Sep 15, 2017 11:44 AM
by Tommy
I tried changing it... but it doesn't work.

It still says my AET e PORT and IP have to be configured in the remote station... which has been already done...

so the same DICOM node configuration is registered both in RadiAnt and in the PACS but RadiAnt doesn't want to download images.

all the other computers in the same network can easily access to that PACS so I don't know what's wrong with that PC.

sometimes other computers show the same error message but if you wait a few minutes and redo the query it works fine.

so I can tell this incomplete communication with the PACS (it's a ClearCanvas PACS) if happens all the time with a single Win7 x32 PC and occasionally with the other Win7 x64 machines

Sep 16, 2017 06:01 AM
by vinu
ok try one more thing also,
allow that program through windows firewall in that PC.
issue may related with firewall settings. I am not sure about this
Sep 16, 2017 08:09 AM
by vuongnm
It's happened to me many times and I solved them. The causes may be some, those are firewall (you can try to temporary disable firewall then try to query and retrieve again), the another common reason is that you did not configure radiant dicom viewer properly so that PACS can recognize it.
Sep 17, 2017 12:32 PM
by RadiAnt
If you can search studies but downloads fail, it means that the PACS server has problems connecting to RadiAnt PC.
RadiAnt uses C-MOVE/C-STORE protocol to download studies. If the server cannot connect back to RadiAnt PC, no studies will be sent from server to RadiAnt (search works because RadiAnt can connect to server but not the other way).
There are many possible reasons - firewall, NAT, other application running on the same port, misconfiguration on the server (it has to know the IP, listener port and AE title of RadiAnt PC), using the same AE title for multiple computers, etc.
Sometimes it may be necessary to use on site the help of someone experienced in setting up PACS connections.
Sep 17, 2017 02:27 PM
by Tommy
it seems I've found where the issue was...
for some reason the latest installed version of RadiAnt was not allowed in the firewall settings, whilst an old RadiAnt version I installed months before in another folder was allowed.

so I removed the old one from the list and activated the new one with the correct path and now images are correctly downloaded.

thanks for the hint.
Sep 17, 2017 05:25 PM
by RadiAnt
If you install RadiAnt in another folder, a new firewall rule must be created.
Usually the system prompts user to allow or disallow network access the first time PACS search window is opened.
Anyway, happy to hear your problem is resolved.
Sep 19, 2017 08:20 AM
by Tommy
yes, the culprit was the change of folder installation.

I was misled by the fact the old folder rule was still visible in the firewall setting but at a closer inspection of the properties I found that the path was different which explained the issue.

Aug 29, 2019 12:49 PM
by Ori
Thanks Tommy!
you r solution to change the title worked for me :)
Aug 29, 2019 12:51 PM
by Ori
I meant vinu...
Jul 21, 2022 03:24 AM
by art hqe
change retrieve protocol from C-MOVE to C-GET
Dec 24, 2023 03:04 AM
by Jeff
Hello @art hqe,
Your solution is effective for DICOM server Sante PACS Server v3.1.8.
// When the protocol is C-MOVE, I can't download images from the server, it shows "C_MOVE SCP failed". But it shows "C_GET SCP Succeeded" after I change the protocol to C_GET.
Post reply
Author (first name or pseudonym):


Captcha image

Visitors can post messages on the forum without having to register. Please input your first name or pseudonym in the "Author" field. Do not publish any personally identifiable information (PII).

Please ensure you write your posts in English so that our international audience can understand and reply to your message.

The Administrator reserves the right to remove any messages that violate our forum rules; for example, those that are not related to the RadiAnt DICOM Viewer software, published in a language other than English, contravene regulations, etc.